Problem getting IMSI number from Start IoT kit (Arduino MKR NB 1500)

Hi.

I’m having trouble getting the IMSI number from my Telenor card with the Arduino MKR NB 1500.
Tried to send an AT command directly to the unit via UART terminal.

AT+CIMI

But I am getting an error:

+CME ERROR: SIM failure

I am getting the right IMEI number though. Is there something I’m doing wrong, or is there a problem with the card or something similar?

Hi @patricab welcome to the forum!

The IMEI is coming from the modem itself and is retrieved with AT+CGSN; The IMSI, which you retrieve with AT+CIMI comes from the SIM thus it’s possible to retrieve the IMEI even if there are issues with the SIM. As a starting point

  1. is the SIM inserted correctly? is it the right way around? (believe it or not, i have caught myself out on this more times than i care to count! - obvious, but worth a double check)
  2. are you using a SIM adapter? or have you had to cut the SIM to size?
  3. are the contacts on either the SIM or SIM adapter dirty? This can be an issue if the device has some age on it, or has been used in corrosive areas (salt are for example) or if the SIM has been plugged in and out a few times - if you can, give the contacts some cleaning with some isopropyl alcohol (just make sure everything is dried before switching back on!)
  4. if you have another device you can test the SIM in or another SIM you can test and we can narrow down the issue

if you are able to retrieve the IMEI then for now it appears the code is working and you have control of the device - so then my suspicion lands on the SIM or SIM interface.

let us know how it goes!

(P.S as this is Arduino specific I have moved this to our Arduino category)

Hi. Sorry for the late reply. Thank you for replying though :slight_smile:

I was able to retrieve the IMSI number, but I’m not quite sure how. As you say, it’s probably the fault of a bad contact surface or something similar. I had inserted the card correctly and had cut off the right size for the card.

Thank you for the help!

Hi @patricab no worries on the late reply mate, glad it worked out for you!

I have had terrible luck with cutting sims to size; I have a sim punch but to be honest I end up using scissors most of the time as I get a better result.

As fate would have it just this afternoon I had a sim failure on one of my boards so went through the same troubleshooting list myself - in this case it was a spring-loaded “push to eject” sim holder that had got misaligned on a cut down sim.

SIM cards are notorious failure points and why I very much prefer the MFF2 (soldered) SIM cards where possible - though they trade reliability for some flexibility in some use cases.

But! Great it works and happy hacking!